通达信筹码突破主图超级好用公式

2021-08-31 17:44:00
key10
转贴
271
M5:MA(C,5);
M10:MA(C,10);
M20:MA(C,20);
M60:MA(C,60);
成交量显示:=1;
MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA60:MA(CLOSE,60);
VAR1:=COST(90);
VAR2:=COST(70);
VAR3:=COST(50);
VAR4:=COST(30);
VAR5:=COST(2);
VAR6:=INTPART(COST(2)*100)/100;
VAR7:=INTPART(COST(0.01)*100)/100;
筹码牛熊:EMA((VAR1+VAR2+VAR3+VAR4+VAR5)/5,3),COLORYELLOW,LINETHICK3;
VAR8:=COST(90)>REF(COST(90),1) AND COST(70)>REF(COST(70),1) AND COST(50)>REF(COST(50),1) AND COST(30)>REF(COST(30),1);
VAR9:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>6 AND VAR8 AND CLOSE>COST(90) AND LOW<COST(90) AND (LOW-筹码牛熊)/筹码牛熊*100<5;
{STICKLINE(VAR9,OPEN,CLOSE,2.4,0),COLORYELLOW;}
WWW70822COM:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
DRAWICON(VAR9,LOW*0.97,13);
VAR10:=FILTER((CLOSE-COST(2))/COST(2)*100<3 AND CLOSE>VAR6 AND VAR6>=REF(VAR6,1),3);
DRAWICON(VAR10,LOW*0.97,38);
VAR11:=BARSLAST(VAR10);
VAR12:=BARSLAST(VAR7<REF(VAR7,1) AND REF(VAR7,1)>=REF(VAR7,2));
DRAWICON(VAR7<REF(VAR7,1) AND REF(VAR7,1)>=REF(VAR7,2) AND REF(VAR11,1)<REF(VAR12,1),HIGH*1.01,39);
STICKLINE(VAR10,OPEN,CLOSE,2,0),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=1 AND CLOSE>0,筹码牛熊,(CLOSE-筹码牛熊)/筹码牛熊*100),COLORWHITE;
所属板块:=STRCAT('所属板块: ',STRCAT(STRCAT(STRCAT('[行业]-',HYBLOCK),STRCAT(' [地域]-',DYBLOCK)),STRCAT(' [概念]-',GNBLOCK)));
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值));
DRAWTEXT_FIX(1,0.980,20,1,'★分析家公式网'),COLOR666666;
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(29)/FINANCE(19)*100,2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(净资收益率,毛利率),主营利润率));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.02,0,所属板块),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.07,0,股本市值),COLORGREEN;

DRAWTEXT_FIX(ISLASTBAR,0.005,0.12,0,当前业绩),COLORGREEN;



百度统计